公式バージョンアップでエラーが発生する場合

投稿者: | 2010年2月27日

本日ハックを全て外したはずなのにバージョンアップでエラーが発生するという報告がありました。

もし、同じような状態になっている方はSettings画面の下にあるKindleのバージョンを確認してください。
もし”)”の後ろに”i”やその他の文字がついている場合、うちのフォントハックまたはytsuboiさんのところにあるフォントハックを二重にインストールしたり、フォントハックをアンインストールせずに上書きしたものと思われます。
これは現在公開しているアンインストーラでの修復はできません。

この状態でAmazon.comの公式アップデートを行うとバージョンチェックで引っかかりアップデートのエラーが発生します。
問題の解消のためのファイルを公開しますので、写真のような状態になっている方は試してみてください。

ついでに、現在のフォント設定ファイルとブラウザの設定ファイルのチェックも行います。
この2つはフォントハックを入れると書き換えを行うファイルです。

チェックしたファイルはUSBドライブのルートにコピーし、チェックサムの値はchecksum_list.txtへ出力します。
prettyversioin.txtとあわせて3ファイルのチェックサムが合っていない状態で公式アップデータを当てるとアップデートに失敗しますので、アップデートを行う前のチェックに使えます。

checksum_list.txをwindowsのメモ帳で開くと改行コードの問題で1行になってしまうので、秀丸など改行コードの自動判定ができるエディタで開くと見やすいです。

kindle2 US版
kindle2 国際版
kindleDX US版
kindleDX 国際版

公式バージョンアップでエラーが発生する場合」への1件のフィードバック

  1. ピンバック: 【Kindle】 Amazon Kindle FAQ – 購入前情報からJailbreakまで 【まとめ】 | をぢの日記

コメントを残す

メールアドレスが公開されることはありません。